root/bdm/config/libconfig-1.3.1/libconfig.spec @ 245

Revision 245, 2.2 kB (checked in by smidl, 16 years ago)

[PATCH] our own copy of libconfig... :(

Line 
1Name:           libconfig
2Version:        1.3.1
3Release:        1
4Summary:        C/C++ Configuration File Library
5Group:          System Environment/Libraries
6License:        LGPLv2+
7URL:            http://hyperrealm.com/main.php?s=libconfig
8Source0:        http://www.hyperrealm.com/libconfig/%{name}-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id} -u -n)
10Packager:       Deneys S. Maartens  <dsm@tlabs.ac.za>
11BuildRequires:  texinfo-tex
12
13%description
14Libconfig is a simple library for processing structured configuration
15files. The file format is more compact and more readable than XML. And
16unlike XML, it is type-aware, so it is not necessary to do string
17parsing in application code.
18
19%package devel
20Summary:        %{name} development package
21Group:          Development/Libraries
22Requires:       %{name} = %{version}-%{release}
23Requires:       pkgconfig
24Requires(post):         /sbin/install-info
25Requires(preun):        /sbin/install-info
26
27%description devel
28Development files for %{name}.
29
30%prep
31%setup -q
32iconv -f iso-8859-1 -t utf-8 -o AUTHORS{.utf8,}
33mv AUTHORS{.utf8,}
34
35%build
36%configure --disable-static
37make %{?_smp_mflags}
38make html pdf
39
40%install
41rm -rf $RPM_BUILD_ROOT
42make DESTDIR=$RPM_BUILD_ROOT install install-pdf
43rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
44
45%clean
46rm -rf $RPM_BUILD_ROOT
47
48%post -p /sbin/ldconfig
49
50%post devel
51/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
52
53%postun -p /sbin/ldconfig
54
55%preun devel
56if [ $1 = 0 ]; then
57  /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
58fi
59
60%files
61%defattr(-,root,root,-)
62%doc AUTHORS COPYING.LIB ChangeLog INSTALL NEWS README
63%{_libdir}/%{name}.so*
64%{_libdir}/%{name}++.so*
65
66%files devel
67%defattr(-,root,root,-)
68%doc AUTHORS COPYING.LIB ChangeLog INSTALL NEWS README
69%doc doc/%{name}.html
70%doc test.cfg
71%doc samples/c/*.c
72%doc samples/c++/*.cpp
73%{_includedir}/libconfig.*
74%{_libdir}/libconfig*.so
75%{_libdir}/pkgconfig/libconfig*.pc
76%{_defaultdocdir}/%{name}/
77%{_infodir}/libconfig.info*
78
79%changelog
80
81* Sun Aug  23 2008  Mark A. Lindner <mark_a_lindner@yahoo.com>  1.3.1
82- updated for 1.3.1
83* Mon Apr  7 2008  Mark A. Lindner <mark_a_lindner@yahoo.com>  1.3
84- updated for 1.3
85* Wed Aug 19 2007  Deneys S. Maartens  <dsm@tlabs.ac.za>  1.1.3-1
86- create spec file
87
88# -fin-
Note: See TracBrowser for help on using the browser.