1 | Name: libconfig |
---|
2 | Version: 1.3.1 |
---|
3 | Release: 1 |
---|
4 | Summary: C/C++ Configuration File Library |
---|
5 | Group: System Environment/Libraries |
---|
6 | License: LGPLv2+ |
---|
7 | URL: http://hyperrealm.com/main.php?s=libconfig |
---|
8 | Source0: http://www.hyperrealm.com/libconfig/%{name}-%{version}.tar.gz |
---|
9 | BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id} -u -n) |
---|
10 | Packager: Deneys S. Maartens <dsm@tlabs.ac.za> |
---|
11 | BuildRequires: texinfo-tex |
---|
12 | |
---|
13 | %description |
---|
14 | Libconfig is a simple library for processing structured configuration |
---|
15 | files. The file format is more compact and more readable than XML. And |
---|
16 | unlike XML, it is type-aware, so it is not necessary to do string |
---|
17 | parsing in application code. |
---|
18 | |
---|
19 | %package devel |
---|
20 | Summary: %{name} development package |
---|
21 | Group: Development/Libraries |
---|
22 | Requires: %{name} = %{version}-%{release} |
---|
23 | Requires: pkgconfig |
---|
24 | Requires(post): /sbin/install-info |
---|
25 | Requires(preun): /sbin/install-info |
---|
26 | |
---|
27 | %description devel |
---|
28 | Development files for %{name}. |
---|
29 | |
---|
30 | %prep |
---|
31 | %setup -q |
---|
32 | iconv -f iso-8859-1 -t utf-8 -o AUTHORS{.utf8,} |
---|
33 | mv AUTHORS{.utf8,} |
---|
34 | |
---|
35 | %build |
---|
36 | %configure --disable-static |
---|
37 | make %{?_smp_mflags} |
---|
38 | make html pdf |
---|
39 | |
---|
40 | %install |
---|
41 | rm -rf $RPM_BUILD_ROOT |
---|
42 | make DESTDIR=$RPM_BUILD_ROOT install install-pdf |
---|
43 | rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la |
---|
44 | |
---|
45 | %clean |
---|
46 | rm -rf $RPM_BUILD_ROOT |
---|
47 | |
---|
48 | %post -p /sbin/ldconfig |
---|
49 | |
---|
50 | %post devel |
---|
51 | /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || : |
---|
52 | |
---|
53 | %postun -p /sbin/ldconfig |
---|
54 | |
---|
55 | %preun devel |
---|
56 | if [ $1 = 0 ]; then |
---|
57 | /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || : |
---|
58 | fi |
---|
59 | |
---|
60 | %files |
---|
61 | %defattr(-,root,root,-) |
---|
62 | %doc AUTHORS COPYING.LIB ChangeLog INSTALL NEWS README |
---|
63 | %{_libdir}/%{name}.so* |
---|
64 | %{_libdir}/%{name}++.so* |
---|
65 | |
---|
66 | %files devel |
---|
67 | %defattr(-,root,root,-) |
---|
68 | %doc AUTHORS COPYING.LIB ChangeLog INSTALL NEWS README |
---|
69 | %doc doc/%{name}.html |
---|
70 | %doc test.cfg |
---|
71 | %doc samples/c/*.c |
---|
72 | %doc samples/c++/*.cpp |
---|
73 | %{_includedir}/libconfig.* |
---|
74 | %{_libdir}/libconfig*.so |
---|
75 | %{_libdir}/pkgconfig/libconfig*.pc |
---|
76 | %{_defaultdocdir}/%{name}/ |
---|
77 | %{_infodir}/libconfig.info* |
---|
78 | |
---|
79 | %changelog |
---|
80 | |
---|
81 | * Sun Aug 23 2008 Mark A. Lindner <mark_a_lindner@yahoo.com> 1.3.1 |
---|
82 | - updated for 1.3.1 |
---|
83 | * Mon Apr 7 2008 Mark A. Lindner <mark_a_lindner@yahoo.com> 1.3 |
---|
84 | - updated for 1.3 |
---|
85 | * Wed Aug 19 2007 Deneys S. Maartens <dsm@tlabs.ac.za> 1.1.3-1 |
---|
86 | - create spec file |
---|
87 | |
---|
88 | # -fin- |
---|